It is currently Tue May 26, 2020 10:32 pm




Post new topic Reply to topic  [ 5 posts ] 
 Nightmare Updating 
Author Message

Joined: Thu Jun 30, 2016 8:44 am
Posts: 10
Post Nightmare Updating
I updated about 70 sites on one server to latest version of TradeExpert using PHP 5.6.40.

Then I asked host to update to PHP 7.2, thinking TE would still work.

Fatal error: The file /home/user/domain.com/go/in.php was encoded by the ionCube Encoder for PHP 5.5 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

That error on every site, that's all people see!

Impossible to run PHP 7.2 install.php as no matter what directories you give 777 permission it complains about not having sufficient permission.

So looks like I will have to download TE backup for each domain, delete install directory via ssh, then reinstall TE, then upload and restore backup for every domain.


Thu Nov 14, 2019 5:20 pm
Profile

Joined: Thu Jun 30, 2016 8:44 am
Posts: 10
Post Re: Nightmare Updating
Installation info
Write permissions Failed, please fix write permission problems, before you proceed with the installation.
Domain name domain.com
PHP version 7.2.24
ionCube loader version 10.3
Safe mode Yes
Allow URL fopen Yes


Thu Nov 14, 2019 5:47 pm
Profile

Joined: Thu Jun 30, 2016 8:44 am
Posts: 10
Post Re: Nightmare Updating
My host found solution by recursively changing owner to www - then it was possible to update tradeexpert to 7.2 using install.php

If anyone else experience this problem now you know the fix :)


Thu Nov 14, 2019 6:40 pm
Profile

Joined: Thu Jun 09, 2016 12:03 am
Posts: 15
Post Re: Nightmare Updating
could you show error.log


Wed Dec 25, 2019 2:31 pm
Profile
Site Admin

Joined: Sat Mar 14, 2009 5:54 pm
Posts: 700
Post Re: Nightmare Updating
Hello,

php 5.6 < 7 are compatible not php 7+, so if you upgrade PHP to 7+ you need to download the new installer for it and run the update because of IonCube loader. If the www user is different then the FTP or SSH, you need to chmod all folders under TE3 to 777 (recursive) and all files to 666 then the permission problems will be fixed, you can chmod it back after the update.


Best regards,
Alex


Sat Jan 04, 2020 8:12 am
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.